Wondering about VRF?

 

 

Capture
===== R2 Config =====

interface GigabitEthernet1/0
ip address 192.168.1.2 255.255.255.0
negotiation auto

ip route 0.0.0.0 0.0.0.0 192.168.1.1

R2#ping 20.20.20.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/52 ms
R2#ping 10.10.10.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
R2#

===== R1 Config =====

interface GigabitEthernet1/0
ip address 192.168.1.2 255.255.255.0
negotiation auto

ip route 0.0.0.0 0.0.0.0 192.168.1.1

R1#ping 10.10.10.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/18/36 ms
R1#ping 20.20.20.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.20, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
R1#

===== R3 config =====
ip vrf BLUE
!
ip vrf RED

interface Loopback10
ip vrf forwarding BLUE
ip address 10.10.10.10 255.255.255.0
!
interface Loopback20
ip vrf forwarding RED
ip address 20.20.20.20 255.255.255.0

interface GigabitEthernet1/0.10
encapsulation dot1Q 10
ip vrf forwarding BLUE
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet1/0.20
encapsulation dot1Q 20
ip vrf forwarding RED
ip address 192.168.1.1 255.255.255.0
R3#sh ip route
Gateway of last resort is not set !! This is global route table, no entries here !!

R3#sh ip vrf RED
Name Default RD Interfaces
RED <not set> Lo20
Gi1/0.20
R3#sh ip vrf BLUE
Name Default RD Interfaces
BLUE <not set> Lo10
Gi1/0.10
R3#sh ip route vrf BLUE
Routing Table: BLUE
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback10
C 192.168.1.0/24 is directly connected, GigabitEthernet1/0.10
R3#sh ip route vrf RED
Routing Table: RED
Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets
C 20.20.20.0 is directly connected, Loopback20
C 192.168.1.0/24 is directly connected, GigabitEthernet1/0.20
R3#

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s